Following our previous announcement about ending support for JetBrains 2025.1.x, we're continuing to update the minimum supported IDE versions for GitHub Copilot.Our general principle is to support approximately one year of JetBrains IDE releases, allowing us to focus on newer platform capabilities while continuing to improve GitHub Copilot's features, stability, and performance.With JetBrains 2026.3 now available, the GitHub Copilot plugin will end support for JetBrains IDEs version 2025.2.x (platform build 252) in the coming months.The minimum supported IDE version will move to 2025.3.x, although we recommend upgrading to 2026.2 or later for the best experience.Who is affectedThis change applies to all users running JetBrains IDEs version 2025.2.x, including its patch releases.If you remain on an affected version after support ends: Your existing GitHub Copilot plugin is expected to continue working and will not be immediately disabled. Future plugin updates may no longer be compatible with your IDE version. You will no longer receive new features, bug fixes, or performance improvements for that IDE version.What we recommendTo continue receiving the latest GitHub Copilot improvements: Check your IDE version: Go to Help > About (Windows/Linux) or [IDE Name] > About (macOS). Upgrade your IDE: Upgrade to at least 2025.3.x, preferably 2026.2 or later, through the JetBrains website. Update GitHub Copilot: Go to Settings > Plugins to check for updates, and restart your IDE if prompted.If you're already using JetBrains 2025.3.x or later, no immediate IDE upgrade is required for this change.Share your feedbackWe value your feedback as we continue improving GitHub Copilot for JetBrains IDEs. You can share your experience through in-product feedback, our GitHub issue tracker, or our private survey.Thank you for using GitHub Copilot!